Logo du forum
 

Forum TTH-News

| Inscription | | Recherche | | FAQ | | Accueil | | Liste des membres |
| Calendrier |
 
Vous n'êtes pas identifié! [Connexion] ou [Inscription] Forum » Software - OS - Réseaux » [Linux] » Plus de connexion SSH: probleme client ou serveur?
Login Mot de passe

4 visiteurs sur ce topic (0 membre(s), 4 invité(s) )


Auteur
Sujet : Plus de connexion SSH: probleme client ou serveur?
Vegan
Vétéran
Membre # 1636

 
Lieu : Area51

Messages :
3185 (0.54 par jour)


Score :

Message du 17-02-2017 @ 11:15   Afficher le profil   Envoyer un message privé   Editer le message   Citer le message      Afficher l'adresse IP   Alerter les modérateurs   


Bonjour,
Je n'arrive plus à me connecter en SSH à mon Raspberry Pi à la maison. J'y étais connecté il y a 10 minutes. Mais j'ai accidentellement interrompu ma session (via le client ssh, sur une machine Linux Mint 18.1). Depuis, le probleme persiste.

(en général, ça se résoud par un reboot des machines, mais comme c'est récurrent, j'aimerais comprendre ;) )
Le Raspberry Pi fonctionne avec la dernière mise à jour de Raspbian.
(le Raspberry Pi fonctionne toujours pour l'instant: j'ai un autre port qui fonctionne et ses services sont actifs)

Pouvez-vous me dire si c'est un souci au niveau client (fichiers à cloturer/effacer?) ou au niveau serveur (Raspberry Pi).


Any idea? Merci... :)
Voici le log de connexion (côté client donc :amoche: ) :

Code :

ssh -vvv rpi@monhote.dyndns.com -p 22
OpenSSH_7.2p2 Ubuntu-4ubuntu2.1, OpenSSL 1.0.2g 1 Mar 2016
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug2: resolving "monhote.dyndns.com" port 22
debug2: ssh_connect_direct: needpriv 0
debug1: Connecting to monhote.dyndns.com [xx.xx.xx.xx] port 22.
debug1: Connection established.
debug1: key_load_public: No such file or directory
debug1: identity file /home/user1/.ssh/id_rsa type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/user1/.ssh/id_rsa-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/user1/.ssh/id_dsa type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/user1/.ssh/id_dsa-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/user1/.ssh/id_ecdsa type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/user1/.ssh/id_ecdsa-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/user1/.ssh/id_ed25519 type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/user1/.ssh/id_ed25519-cert type -1
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_7.2p2 Ubuntu-4ubuntu2.1
ssh_exchange_identification: read: Connection reset by peer
user1@Machineclient ~ $




[message édité le 17-02-2017 @ 11:30 Par Vegan]
----------
Amicalement vôtre
- Haut de page -
bEsTiAn
Le fauve du forum
Membre # 6846

 Avatar du membre
Lieu : Neigembos

Messages :
13202 (2.47 par jour)


Score :

Message du 17-02-2017 @ 14:47   Site personnel   Afficher le profil   Envoyer un message privé   Editer le message   Citer le message      Afficher l'adresse IP   Alerter les modérateurs   

ca me parait pourtant clair :

debug1: key_load_public: No such file or directory
debug1: identity file /home/user1/.ssh/id_rsa type -1

tu n'as pas de clef pour t'identifier
----------
chwi fatigué...
HP 2540p + HP 650g1
- Haut de page -
Vegan
Vétéran
Membre # 1636

 
Lieu : Area51

Messages :
3185 (0.54 par jour)


Score :

Message du 17-02-2017 @ 15:21   Afficher le profil   Envoyer un message privé   Editer le message   Citer le message      Afficher l'adresse IP   Alerter les modérateurs   

Merci pour ta réponse :)

clair clair... key_load_public me semblait pouvoir dire qu'il ne peut pas en obtenir du serveur (client blacklisté ou autre).
J'ai essayé depuis 2 autres config (totalement indépendantes, dont mon smartphone en 4G): idem, pas de connexion au serveur.

Du coup, ça veut dire que ces fichiers (ou d'autres) sont corrompus sur le serveur? (avant de killer accidentellement ma session ssh, j'étais connecté) ... ?
J'ai viré le ~/.ssh côté client et ça n'a rien changé (bon, je m'y attendais... mais c'est vérifié).

Merci à nouveau...



[message édité le 17-02-2017 @ 16:10 Par Vegan]
----------
Amicalement vôtre
- Haut de page -
bEsTiAn
Le fauve du forum
Membre # 6846

 Avatar du membre
Lieu : Neigembos

Messages :
13202 (2.47 par jour)


Score :

Message du 20-02-2017 @ 16:10   Site personnel   Afficher le profil   Envoyer un message privé   Editer le message   Citer le message      Afficher l'adresse IP   Alerter les modérateurs   

tu peux te connecter avec un password ?
alors debug en local sur le serveur
(tu peux faire un ssh 127.0.0.1 aussi)
----------
chwi fatigué...
HP 2540p + HP 650g1
- Haut de page -
Vegan
Vétéran
Membre # 1636

 
Lieu : Area51

Messages :
3185 (0.54 par jour)


Score :

Message du 21-02-2017 @ 13:55   Afficher le profil   Envoyer un message privé   Editer le message   Citer le message      Afficher l'adresse IP   Alerter les modérateurs   

J'ai rebooté le serveur, et ça a marché durant 1 jour.

Par contre, ça ne fonctionne de nouveau plus aujourd'hui et je m'attends à ce que ca remarche après un reboot.
Entre temps, j'ai tout de même noté qu'après un sudo apt-get update && apt-get upgrade, j'ai tout de même quelques paquets qui ne s'installent pas (segfault lors du apt-get upgrade), dont ca-certificates...
J'ai bien essayé toutes les combinaisons apt-get clean autoclean remove autoremove avant, mais rien n'y a fait.
J'ai aussi fait un filesystemcheck mais je ne sais pas où regarder pour voir ce qu'il a éventuellement corrigé...
----------
Amicalement vôtre
- Haut de page -
bEsTiAn
Le fauve du forum
Membre # 6846

 Avatar du membre
Lieu : Neigembos

Messages :
13202 (2.47 par jour)


Score :

Message du 21-02-2017 @ 13:57   Site personnel   Afficher le profil   Envoyer un message privé   Editer le message   Citer le message      Afficher l'adresse IP   Alerter les modérateurs   

dmesg ca dit quoi ?
----------
chwi fatigué...
HP 2540p + HP 650g1
- Haut de page -
Vegan
Vétéran
Membre # 1636

 
Lieu : Area51

Messages :
3185 (0.54 par jour)


Score :

Message du 24-02-2017 @ 16:01   Afficher le profil   Envoyer un message privé   Editer le message   Citer le message      Afficher l'adresse IP   Alerter les modérateurs   

Pas d'erreur mentionnée. Je vais checker l'intégrité physique de la carte mémoire... je n'ai toujours pas trouvé de carte microSD en puce MLC. Utiliser un stick USB à la place n'est pas envisageable: le périphérique connecté exige que l'USB soit bridé à 12Mbps (en tous cas, ça marche bcp mieux ainsi).


----------
Amicalement vôtre
- Haut de page -


Aller dans le forum :  

Plan du forum | Contacter l'administrateur

Powered by SoulBB 3.0.1
© Soulmanto, 2003-2010

Valid XHTML 1.0 Transitional

Page générée en 0.044 secondes